Ingo Karstein's Blog

SharePoint & PowerShell

How to install SharePoint Server 2010 Language Pack SP1.

Posted by Ingo Karstein on 2012/06/20

When you install SharePoint Server 2010 by using the official slipstreamed version that includes SP1 you may get an error while installing SP1 for several language packs.

“The expected version of the product was not found on the system – Error when trying to Install SharePoint Service pack”

Today I had this problem with this language packs:

  • German
  • French
  • Spain
  • Russian

Looking around the internet there was exactly the same issue described in a forum post:

(german, sorry. Try this automatic translation:

…but no solution.

I’ve found several hints in the internet that this is caused by using the official “SharePoint Server 2010 with SP1” setup media.


Some times later I found this site:


I tried to use the trick for the language pack SP1 installers:


W:\SP_Setup\240_SP1\SPS\serverlanguagepack2010sp1-kb2460056-x64-fullfile-de-de.exe PACKAGE.BYPASS.DETECTION.CHECK=1


This solved my issue. I was able to install the SP1 for all affected language packs. – I’m not sure this is a valid procedure for production systems.

One Response to “How to install SharePoint Server 2010 Language Pack SP1.”

  1. Thank you very much! I’ve been struggling with this issue and had not found any solution until your posting. I appreciate it.

Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s


Get every new post delivered to your Inbox.

Join 58 other followers

%d bloggers like this: